Retrobike Forum Index

It is currently Sat Dec 03, 2016 11:11 am

* Login   * Register * Search  * FAQ



Post new topic Reply to topic  [ 27 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject:
PostPosted: Fri Aug 31, 2012 10:52 pm 
retrobike rider
retrobike rider
User avatar

Joined: Wed Mar 03, 2010 11:59 am
Posts: 4437
Location: Near Southampton
...I never ride without my walkman...complete with orange foamy headphones...check ma style!


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 02, 2012 9:36 pm 
Retro Guru
User avatar

Joined: Thu Jul 29, 2010 10:50 pm
Posts: 610
Location: New Zealand
a little "Milli Vanilli" on that walkman wookie?? :wink:


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 02, 2012 9:38 pm 
retrobike rider
retrobike rider
User avatar

Joined: Wed Mar 03, 2010 11:59 am
Posts: 4437
Location: Near Southampton
..Pa leeese! Del la soul and Public Enemy BITD!!!


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 02, 2012 9:39 pm 
Retro Guru
User avatar

Joined: Thu Jul 29, 2010 10:50 pm
Posts: 610
Location: New Zealand
:lol: word.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 02, 2012 9:45 pm 
retrobike rider
retrobike rider
User avatar

Joined: Wed Mar 03, 2010 11:59 am
Posts: 4437
Location: Near Southampton
:D ...to ya momma!


Top
 Profile  
 
 Post subject:
PostPosted: Mon Sep 03, 2012 7:45 pm 
North West Deputy AEC
North West Deputy AEC
User avatar

Joined: Thu Dec 03, 2009 8:32 pm
Posts: 1026
Location: Idle hill
Sounds like the bottom pivot bushing on the shock needs cleaning/lubing thats all,


Top
 Profile  
 
 Post subject:
PostPosted: Mon Sep 03, 2012 7:58 pm 
retrobike rider
retrobike rider
User avatar

Joined: Wed Mar 03, 2010 11:59 am
Posts: 4437
Location: Near Southampton
...seems to have stopped...for now! Mind you it seemed to happen the ride after a wet muddy ride. After I had cleaned it and probably removed any lube that was in the linkage! After a few "dry-er" rides it seems better. We have a had a shitty year for weather I've been cleaning it after every ride at the mo and I've managed to clock up over 2000 off road miles this year! So why do I still have a beer belly!!! Oh well perhaps thats just the age I'm at!

Thanks all the help and advise guys

Wook


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 27 posts ]  Go to page Previous  1, 2, 3

All times are UTC [ DST ]


Who is online

Users browsing this forum: Adruzzz, Majestic-12 [Bot], Mike Muz 67 and 20 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

About Us

Follow Retrobike

Other cool stuff

All content © 2005-2015 Retrobike unless otherwise stated.
Cookies Policy.
bikedeals - the best bike deals in one place
FatCOGS - Fat Chance Owner's Group

Powered by phpBB® Forum Software © phpBB Group