Retrobike Forum Index

It is currently Fri Dec 09, 2016 9:00 pm

* Login   * Register * Search  * FAQ

Forum rules


**Classified Rules & Guidance - Feedback - Dispute Procedure - Gold Trader Status - All Adverts Need A Price - 5 Adverts Maximum - Leave Prices In Sold Adverts - No cross posting adverts**



Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Thu Mar 14, 2013 6:57 pm 
Retro Guru
User avatar

Joined: Fri Oct 08, 2010 11:15 pm
Posts: 524
Location: Canada
Ok I know this is a long shot...but for my 854 restoration i am missing one of these. can anyone help me out? (see build link in my signature...)


Attachments:
Capture.JPG
Capture.JPG [ 104.84 KiB | Viewed 83 times ]
Top
 Profile  
 
PostPosted: Mon Aug 19, 2013 3:51 pm 
Old School Hero

Joined: Sat Jan 08, 2011 4:04 pm
Posts: 196
Location: South Yorkshire
Mine dropped out soon after purchase, just used barend plugs :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

About Us

Follow Retrobike

Other cool stuff

All content © 2005-2015 Retrobike unless otherwise stated.
Cookies Policy.
bikedeals - the best bike deals in one place
FatCOGS - Fat Chance Owner's Group

Powered by phpBB® Forum Software © phpBB Group