Retrobike Forum Index

It is currently Sun Dec 04, 2016 3:24 am

* Login   * Register * Search  * FAQ



Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Thu Aug 22, 2013 6:49 am 
gold | rider | rBoTM
gold | rider | rBoTM
User avatar

Joined: Sat Jan 05, 2013 5:06 pm
Posts: 10239
Location: The deep South
Hi folks ,
Wanted to know if anyone out there has had problems with their Continental presta valved inner tubes . I bought some new ones on evil bay a while ago , and had two of the centre brass threaded bits break off in the last couple of weeks ! I'm not ham fisted !
Mike 8)


Top
 Profile  
 
PostPosted: Thu Aug 22, 2013 5:22 pm 
retrobike rider / Gold Trader
retrobike rider / Gold Trader
User avatar

Joined: Sat May 09, 2009 11:46 pm
Posts: 3922
Location: East Riding of Yorkshire
The only ones I have are Race Lights I use in my Grand Prixs, but haven't had any problems with the valves in the two pairs I've had.


Top
 Profile  
 
PostPosted: Fri Aug 23, 2013 5:54 am 
gold | rider | rBoTM
gold | rider | rBoTM
User avatar

Joined: Sat Jan 05, 2013 5:06 pm
Posts: 10239
Location: The deep South
Maybe I do have the dexterity of a t-rex then after all ! :(


Top
 Profile  
 
PostPosted: Fri Aug 23, 2013 7:37 am 
retrobike rider
retrobike rider
User avatar

Joined: Tue Dec 21, 2010 10:03 pm
Posts: 1345
Location: Birkenhead
Nah, I only use Conti presta tubes as well and never had any issues....

Only grumble I've got is that they've changed the colour of the valve caps from yellow to black!


Top
 Profile  
 
PostPosted: Fri Aug 23, 2013 10:57 am 
Old School Grand Master

Joined: Tue Oct 09, 2007 1:55 pm
Posts: 8202
Location: New Forest, UK
Had the odd one go, they seem to happen in phases. Last time it was 'valve rip-out disease'.


Top
 Profile  
 
PostPosted: Fri Aug 23, 2013 1:33 pm 
Gold Trader
Gold Trader
User avatar

Joined: Fri Jan 23, 2009 2:30 pm
Posts: 12401
Location: Surrey
I've had issues like this, though found it to be pump specific. No problems with a track pump, but when using a mini pump I've broken the odd one, despite being careful.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: Eagach, Yahoo [Bot] and 21 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

About Us

Follow Retrobike

Other cool stuff

All content © 2005-2015 Retrobike unless otherwise stated.
Cookies Policy.
bikedeals - the best bike deals in one place
FatCOGS - Fat Chance Owner's Group

Powered by phpBB® Forum Software © phpBB Group