Retrobike Forum Index

It is currently Mon Oct 24, 2016 11:43 am

* Login   * Register * Search  * FAQ

Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Fri May 03, 2013 7:07 pm 
Retro Guru

Joined: Thu Sep 01, 2011 5:11 pm
Posts: 1043
Location: Left Coast of Canada
Hi Guys:

Last night I was setting up the gears on my zaskar work bike build and I found that the front mech was siezed (I guess it didn't like the deicing salt last winter). I've sprayed it with copious amounts of WD40, soaked it in MEC chain degreaser, cleaned as much of the muck off of it with a clean rag and manipulated the mechanism with a lever. Its getting better, but it still sticks on occasion in the extended position.

With all of the experience in brining used mechs back to life there are a lot of good ideas here about how to get this to function 100%. Any help will be much appreciated.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC [ DST ]

Who is online

Users browsing this forum: Exabot [Bot], mattr and 50 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

About Us

Follow Retrobike

Other cool stuff

All content © 2005-2015 Retrobike unless otherwise stated.
Cookies Policy.
bikedeals - the best bike deals in one place
FatCOGS - Fat Chance Owner's Group

Powered by phpBB® Forum Software © phpBB Group