Retrobike Forum Index

It is currently Sat Dec 10, 2016 10:28 am

* Login   * Register * Search  * FAQ



Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Thu Mar 21, 2013 5:47 pm 
Gold Trader | rBoTM Winner
Gold Trader | rBoTM Winner
User avatar

Joined: Fri Oct 19, 2012 12:30 am
Posts: 2389
Location: London
I've a pump but how and what to do I connect it?
Or am I missing a valve or something?


Top
 Profile  
 
 Post subject: Cancelled post
PostPosted: Thu Mar 21, 2013 6:08 pm 
Gold Trader | rBoTM Winner
Gold Trader | rBoTM Winner
User avatar

Joined: Fri Oct 19, 2012 12:30 am
Posts: 2389
Location: London
Cancel that
Worked it out
Just unscrewed little nobs on he forks!

Easy :)


Top
 Profile  
 
PostPosted: Thu Mar 21, 2013 9:24 pm 
Old School Grand Master
User avatar

Joined: Fri May 01, 2009 7:11 pm
Posts: 8479
Location: Fircombe.
Keep that pump straight!
:wink:


Top
 Profile  
 
PostPosted: Thu Mar 21, 2013 10:55 pm 
Old School Grand Master
User avatar

Joined: Sun Mar 14, 2010 3:07 pm
Posts: 4211
Location: London for my sin's
Sis they not learn the epic epic fail form the hydro pro 1/2. 3 pumps i went through for those damn pro 2's!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: mnsport, Mugoftea, stuey and 52 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  

About Us

Follow Retrobike

Other cool stuff

All content © 2005-2015 Retrobike unless otherwise stated.
Cookies Policy.
bikedeals - the best bike deals in one place
FatCOGS - Fat Chance Owner's Group

Powered by phpBB® Forum Software © phpBB Group